Issues with mChat

Support area for phpBB's mChat extension
MoreThan4LessThan20
Posts: 4
Joined: 15 Aug 2017, 17:45

Issues with mChat

Post by MoreThan4LessThan20 » 16 Aug 2017, 00:52

Hello everyone.

I recently installed the mChat extension (mChat-2.0.1) on my phpBB 3.1.10 forum. I followed the instructions in the readme.md and the chat window now shows up on the forum's index page, however, text messages cannot be sent. An error message pops up which reads "Not found", and when I click on the mChat[0] quick link, it takes me to a webpage (forum root/app.chat/mchat/) that reads "No input file specified." I am not sure, maybe I'm missing some files? I directly downloaded the .zip file linked on GitHub.

Here is what I have tried so far, which hasn't helped.

1. Setting all directories, subdirectories, and files permissions to 777 in dmzx folder.
2. Purged forum cache.
3. Disabled URL rewriting (wasn't enabled to begin with).
4. Set proper user permissions for using mchat.
5. Set style to prosilver.

Thank you to anyone who takes the time to read this and respond.

User avatar
kasimi
mChat developer
Posts: 1079
Joined: 06 Oct 2016, 09:56
Location: Germany

Re: Issues with mChat

Post by kasimi » 16 Aug 2017, 08:01

Can you share a link to your board? Post it here or in a PM if you prefer.

User avatar
kasimi
mChat developer
Posts: 1079
Joined: 06 Oct 2016, 09:56
Location: Germany

Re: Issues with mChat

Post by kasimi » 16 Aug 2017, 22:10

/app.php/mchat gives me the "No input file specified" error, but your board responds to /mchat just fine, I see the login screen. What do you see when you access /mchat? Please send me a test account that has access to mChat.

MoreThan4LessThan20
Posts: 4
Joined: 15 Aug 2017, 17:45

Re: Issues with mChat

Post by MoreThan4LessThan20 » 16 Aug 2017, 22:13

When I access (forum root)/mchat, the mchat window pops up. However, nothing can be typed without the "Error: Not found" message popping up. I'll make you a quick login. PMing you the information.

User avatar
kasimi
mChat developer
Posts: 1079
Joined: 06 Oct 2016, 09:56
Location: Germany

Re: Issues with mChat

Post by kasimi » 16 Aug 2017, 22:50

It most likely is an error in your .htaccess file. Did you modify it in any way?

MoreThan4LessThan20
Posts: 4
Joined: 15 Aug 2017, 17:45

Re: Issues with mChat

Post by MoreThan4LessThan20 » 16 Aug 2017, 23:09

Yes...
"""
<IfModule mod_rewrite.c>
RewriteEngine on

#
# Uncomment the statement below if URL rewriting doesn't
# work properly. If you installed phpBB in a subdirectory
# of your site, properly set the argument for the statement.
# e.g.: if your domain is test.com and you installed phpBB
# in http://www.test.com/phpBB/index.php you have to set
# the statement RewriteBase /phpBB/
#
RewriteBase /community/
"""


I uncommented the 'RewriteBase /community/' line because of how the index.php file is being accessed for the board. Is this not correct? Should I try commenting it again?

User avatar
kasimi
mChat developer
Posts: 1079
Joined: 06 Oct 2016, 09:56
Location: Germany

Re: Issues with mChat

Post by kasimi » 17 Aug 2017, 07:40

This problem isn't limited to mChat. You won't be able to use any extension that uses custom routes.

Try using an unmodified .htaccess file. I've never had to modify the .htaccess file for routing to work, even if the board was in a subfolder. If nothing works, ask your host.

MoreThan4LessThan20
Posts: 4
Joined: 15 Aug 2017, 17:45

Re: Issues with mChat

Post by MoreThan4LessThan20 » 17 Aug 2017, 12:51

Hello Kasimi, since you checked the extension and the issue was determined to either be my .htaccess file or server configurations, I messed around with the server settings. I got it to work! You'll be frustrated/relieved to learn that I had to set "Enable URL Rewriting:" to "YES" to solve the issue. Thank you for your support and patience!

EDIT: I'm also going to delete the Kasimi account I made for you. Thanks again!

User avatar
kasimi
mChat developer
Posts: 1079
Joined: 06 Oct 2016, 09:56
Location: Germany

Re: Issues with mChat

Post by kasimi » 17 Aug 2017, 13:21

Glad you got it fixed. :+1:

terry2
Donor
Posts: 220
Joined: 22 Oct 2016, 18:22
Location: My castle

Re: Issues with mChat

Post by terry2 » 19 Aug 2017, 21:08

If you needed url rewrite on then the problem is with the host (99% of ppl turn it ON to keep the links looking nice anyway)

Who is online

Users browsing this forum: CCBot [Bot] and 0 guests