Board3 Block Problem

Support area for phpBB's mChat extension
Post Reply
Ypselon
Posts: 2
Joined: 03 Oct 2018, 08:11

Board3 Block Problem

#1

Post by Ypselon » 03 Oct 2018, 08:35

I hope someone can help me.

I Use phpBB 3.2.3 and PHP 7.2 with Board3 and Mchat 2.1.0

Now i will Display the mChat Box on the Portal Page, the Block works, but i cant write any Text in mChat. (I See the Smilies, the Text Field)

In the Forum Index it works without Problems. Only in the Board3 Page i have Problems ...

This is the Screen : Image

User avatar
kasimi
mChat developer
Posts: 737
Joined: 06 Oct 2016, 09:56
Location: Germany
Contact:

Re: Board3 Block Problem

#2

Post by kasimi » 03 Oct 2018, 08:40

Hi Ypselon :wave:

It sounds like you have a JavaScript error. Could be coming from mChat or some other extension. Check your browser's error console.

Tigers
Donor
Posts: 25
Joined: 25 Nov 2016, 09:42

Re: Board3 Block Problem

#3

Post by Tigers » 03 Oct 2018, 08:48


Ypselon
Posts: 2
Joined: 03 Oct 2018, 08:11

Re: Board3 Block Problem

#4

Post by Ypselon » 03 Oct 2018, 09:08

kasimi wrote:
03 Oct 2018, 08:40
Hi Ypselon :wave:

It sounds like you have a JavaScript error. Could be coming from mChat or some other extension. Check your browser's error console.
Yes youre right. I got this :

Code: Select all

Uncaught TypeError: m[d].replace is not a function
    at ckeditor.js?assets_version=83:574
    at ckeditor.js?assets_version=83:608
    at ckeditor.js?assets_version=83:1019
ckeditor.js?assets_version=83:251 Uncaught TypeError: Cannot read property 'replace' of undefined
    at n (ckeditor.js?assets_version=83:251)
    at ckeditor.js?assets_version=83:250
    at ckeditor.js?assets_version=83:476
    at window.CKEDITOR.window.CKEDITOR.dom.CKEDITOR.resourceManager.<anonymous> (ckeditor.js?assets_version=83:239)
    at h (ckeditor.js?assets_version=83:234)
    at Array.n (ckeditor.js?assets_version=83:234)
    at v (ckeditor.js?assets_version=83:235)
    at ckeditor.js?assets_version=83:235
   
I use the Rin Editor ( https://github.com/martec/Rin-Editor_for_phpBB ) Versions before 2.1.0 from mChat works

User avatar
kasimi
mChat developer
Posts: 737
Joined: 06 Oct 2016, 09:56
Location: Germany
Contact:

Re: Board3 Block Problem

#5

Post by kasimi » 03 Oct 2018, 09:37

It worked with mChat before 2.1.0 because it didn't use a textarea as input field by default. If you went to your UCP mChat settings in 2.0.3 and switched to use a textarea, I'm pretty sure you would have seen the same errors.

You should ask the author of the WYSIWYG editor.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest