mchat not showing up on extensions tab in ACP

Support area for phpBB's mChat extension
Post Reply
Gnome
Posts: 4
Joined: 24 Dec 2018, 06:58

mchat not showing up on extensions tab in ACP

#1

Post by Gnome » 24 Dec 2018, 07:13

Hey Kasimi,

Thanks for making such an awesome extension for phpBB sites. I just added your extension to my site and a mchat window does show up on the index page, so it appears to be working (I typed a few things and they posted). However, when I go the the extensions tab in ACP, mchat does not show up, so I can't customize any of the settings. I attached an screenshots of my ACP so you can see what I am talking about... I don't know if I am missing something silly, but I saw some of your screen shots that show this tab (but mine does not). Thank you for your time. I also

Regards.
Attachments
versions.png
showing thePHP and SQL versions on my site
versions.png (27.95 KiB) Viewed 177 times
versions.png
showing thePHP and SQL versions on my site
versions.png (27.95 KiB) Viewed 177 times
extensions tab.png
ext tab with no mchat in left column
extensions tab.png (455.86 KiB) Viewed 177 times
extensions tab.png
ext tab with no mchat in left column
extensions tab.png (455.86 KiB) Viewed 177 times
enabled pic.png
customize tab showing enabled mchat extension
enabled pic.png (25.63 KiB) Viewed 177 times
enabled pic.png
customize tab showing enabled mchat extension
enabled pic.png (25.63 KiB) Viewed 177 times

User avatar
kasimi
mChat developer
Posts: 887
Joined: 06 Oct 2016, 09:56
Location: Germany
Contact:

Re: mchat not showing up on extensions tab in ACP

#2

Post by kasimi » 24 Dec 2018, 08:05

Hi Gnome :wave:

Do you see the mChat settings in your UCP module? What about the two tabs for mChat permissions in the (global) user permission section?

In your ACP, go to Module Management in the System tab, go to ACP and then to Extensions. Is mChat listed there? Make sure it's enabled.

Gnome
Posts: 4
Joined: 24 Dec 2018, 06:58

Re: mchat not showing up on extensions tab in ACP

#3

Post by Gnome » 24 Dec 2018, 16:00

Thank you for your prompt reply! I can see the mChat in my UCP (picture attached). in the ACP, I do not see the options either in the global 'User and Groups' tab nor the Extensions tab. It is enabled on the systems tab (picture attached). I am running PHPBB 3.2.2 and MySQL(i) 5.6.41-84.1.
Attachments
Global UCP.png
Showing mchat module enabled
Global UCP.png (165 KiB) Viewed 168 times
Global UCP.png
Showing mchat module enabled
Global UCP.png (165 KiB) Viewed 168 times
UCP.png
UCP with mChat tab
UCP.png (217.7 KiB) Viewed 168 times
UCP.png
UCP with mChat tab
UCP.png (217.7 KiB) Viewed 168 times

User avatar
kasimi
mChat developer
Posts: 887
Joined: 06 Oct 2016, 09:56
Location: Germany
Contact:

Re: mchat not showing up on extensions tab in ACP

#4

Post by kasimi » 25 Dec 2018, 15:26

To be clear, in ACP, System tab, ACP module management, select the Extensions module. There is no mChat module listed there?

Is this is a first time install of mChat? If so, disable mChat, delete data, make sure all extension files are uploaded correctly, most importantly all files in the migrations folder, and then enable mChat again.

Gnome
Posts: 4
Joined: 24 Dec 2018, 06:58

Re: mchat not showing up on extensions tab in ACP

#5

Post by Gnome » 25 Dec 2018, 19:05

Kasimi wrote:To be clear, in ACP, System tab, ACP module management, select the Extensions module. There is no mChat module listed there?
The mChat module is listed in ACP in the System Tab, under module management (ACP) (picture attached)
Kasimi wrote:Is this is a first time install of mChat? If so, disable mChat, delete data, make sure all extension files are uploaded correctly, most importantly all files in the migrations folder, and then enable mChat again.
This is the first time install of the extension... I will try this now and report back

Thanks again for your work on this strange matter!

Gnome
Posts: 4
Joined: 24 Dec 2018, 06:58

Re: mchat not showing up on extensions tab in ACP

#6

Post by Gnome » 26 Dec 2018, 04:44

I deleted the data, disabled the extension, and deleted the folder. I then re-downloaded the mchat extension from the phpbb extension website and re-installed it... and I still have the same problem.

User avatar
kasimi
mChat developer
Posts: 887
Joined: 06 Oct 2016, 09:56
Location: Germany
Contact:

Re: mchat not showing up on extensions tab in ACP

#7

Post by kasimi » 28 Dec 2018, 19:38

Run these two queries in phpMyAdmin or similar and post the results:
  1. Code: Select all

    SELECT migration_name
    FROM phpbb_migrations
    wHERE migration_name LIKE '%mchat%'
    
  2. Code: Select all

    SELECT module_basename, module_mode
    FROM phpbb_modules
    wHERE module_basename LIKE '%mchat%'
    
Edit: only now it occurred to me that the most likely cause is that you're not using one of the default roles for your administrator group. Only the default roles are granted access to manage mChat settings. Roles that you created yourself need to be granted permission manually. There's an admin permission "Can manage mChat" that you need to give whoever you want to be able to change mChat settings.

Post Reply

Who is online

Users browsing this forum: kaptangula and 1 guest