Missing moderation buttons

Support area for phpBB's mChat extension
Post Reply
Onki
Posts: 4
Joined: 23 Mar 2019, 08:49

Missing moderation buttons

#1

Post by Onki » 23 Mar 2019, 08:57

Hello folks,
i have just installed mChat on a phpBB 3.2.5.
Unfortunately I have the problem that there are no moderation icons next to the messages. I miss the icon for editing and deleting messages.
The icon for quoting and user permissions is present.

I have given the administrators (myself included) all the permissions that are available for mChat, including the ability to edit or delete messages from other users.

The forum isn't live yet, so I can't link it to you yet.
Is it maybe a version problem? I have the latest mChat version.

If you have ideas, I would be happy.

Thank you
Onki

User avatar
kasimi
mChat developer
Posts: 935
Joined: 06 Oct 2016, 09:56
Location: Germany
Contact:

Re: Missing moderation buttons

#2

Post by kasimi » 23 Mar 2019, 10:15

Hi Onki :wave:

You are the first who reports this kind of issue, I'm pretty sure it's a problem with your permissions. Did you make sure that you have the correct permissions by checking your user account? Go to: ACP, Users & groups, Manage users, Enter your username, select Permissions from the top right dropdown and check the mChat tab in the User permissions section.

Onki
Posts: 4
Joined: 23 Mar 2019, 08:49

Re: Missing moderation buttons

#3

Post by Onki » 23 Mar 2019, 19:29

Hi kasimi,

thank you for your reply and even more "thank you" for this great plugin.
I used your solution and it works, I'm just confused because usually I try to set permissions only with user groups and try to avoid set permissions for single users.

Onki

User avatar
kasimi
mChat developer
Posts: 935
Joined: 06 Oct 2016, 09:56
Location: Germany
Contact:

Re: Missing moderation buttons

#4

Post by kasimi » 23 Mar 2019, 20:08

I was only suggesting to use the user's permission page as a way to find out why you can't see these icons. Using permission roles that are linked to groups is the preferred way over setting permissions on a per-user basis, I totally agree.

So before you changed the user's mChat permissions, did the "Can delete" and "Can edit" mChat permissions for that user say they were set to No? If you decide to stick with giving permissions through groups, undo the user permissions by setting them all back to No. Head back to your permission roles and make sure you edited the correct ones: a role needs to be linked to the group the user is in for its permissions to take effect. Also make sure none of the groups/roles have these permissions set to Never.

Onki
Posts: 4
Joined: 23 Mar 2019, 08:49

Re: Missing moderation buttons

#5

Post by Onki » 10 May 2019, 07:22

Hey kasimi,

thanks for your support. It works now.
It was indeed a permission problem caused by differend groups which got their permissions of other groups and so on.
I'm not the owner of the board I administrate. Plan is to clean up the permissions, it's a mess ;)

Thanks for your support. Great work!

Post Reply

Who is online

Users browsing this forum: Bing [Bot] and 1 guest